Reserved characters

Oct 26, 2010 at 6:20 PM

Hi,

I'm transferring files from floppy to sd2iec using cbm-command. Some c64 filenames contain FAT reserved characters like slash. Could you please change these characters to underscore for instance, otherwise the file won't be written to FAT.

Cheers,

Duncan

Coordinator
Oct 26, 2010 at 6:29 PM
Changing filenames is not something I can/want to do for these reasons

1) It will break applications expecting specific files
2) I need to know what kind of device is being used, specifically that the
device is using FAT file system and not a CBM file system, currently there
is no reliable way to do this.
3) uIEC already supports this by turning on the feature that writes all PRG
files using the .P00 format and all SEQ files using the .S00 formats. This
preserves the CBM specific filenames, but makes the directory look like
crap in Windows.

Payton Byrd
-----------
http://www.paytonbyrd.com
http://it.toolbox.com/blogs/paytonbyrd

-------- Original Message --------
-> From: "DuncanTwain" <[email removed]>
-> Sent: Tuesday, October 26, 2010 1:22 PM
-> To: [email removed]
-> Subject: Possible SPAM Reserved characters [cbmcommand:232397]
->
-> From: DuncanTwain
->
-> Hi,I'm transferring files from floppy to sd2iec using cbm-command. Some
c64 filenames contain FAT reserved characters like slash. Could you please
change these characters to underscore for instance, otherwise the file
won't be written to FAT.Cheers,Duncan
->
->
Oct 26, 2010 at 7:23 PM

I see your points. Maybe a switch could be an option? Otherwise transferring complete .d64 images is quite a good solution; wonderful option anyway!